Build Error when attempting to replace a file

I’m having an issue with a simple “replace” deployment. We are trying to replace a file. When I run the build the I get an error the states “no such file or directory” - see screenshot. This was happening with v4.3.4 and is still happening after upgrading for 4.4. The referenced file path does exist.

Hello Patrick,

Could you give us more information about your deployment? Sending us the full deployment and logs might let us see what’s different about your situation.

Any chance there is an odd character in your path?


There are no odd characters in the file names. Attached are log files from the last time I tried the deployment with a JiT build. It also failed. The screenshot above was from just trying to create a build via the OttoDeploy file. It doesn’t seem to have additional log files associated with that.

One other weird issue is that I get an error message “Failed to Fetch” when I select the option to download both as a zip file. Downloading the files individually worked fine. (2.2 KB)

Ok these are two separate problems I think. Lets break them down.

Backup failed ENONT error. That was from just doing a build, right? That isn’t even a deployment yet. You are just doing the build in preparation for a deployment? Is that right?

Does that fail every time you do that build?

The second error, is from a JIT build and maybe related to the server not being able to create a build in the first place. But it might be different.

ENOENT might be a permissions problem. Are you sure you have full disk access and the other permissions setup properly on your Backups Volume?


1 Like

Otto is using an external drive connected to the Mac. Otto had full disk access enabled and permissions were set on the folders properly for FileMaker access (fmserver:fmsadmin). FileMaker was able to write to the directories for backups and Otto was able to create the folders and files when starting a build but would then fail.

Solution: I enable “Ignore Permissions” for the external drive and builds and deployments started working properly again.

Thanks Patrick, really good info.

We will add this to the docs.