I have a migration that never fully completes, stalls at post-deployment step

Hi Tom,

Is you backup disk a slow spinning disk? If it is and your files are large it may just be taking forever to move the files back after migration. How big are your files?

You could test this by setting your default Backup to location on Drive D. Restart OttoFMS and then give it a try. OttoFMS will do it’s work on Drive D and it won’t have to copy the file from E: to D:

That is one thing that is different from Otto3. OttoFMS uses your backup drive to do the migrations. Otto3 did the migrations right in the DB drive.

Todd

Todd,

The files I’m migrating are mainly interface files 50MB, 38MB, and 280MB. It’s a virtual server in Azure with premium-level SSD disks.
I restarted the server and did four migrations, adding a file after each migration, each larger than the last.
First migration 38MB
Second, added the 50MB
Third, added the 280MB
All were successful, which is great.
So I added one more file that was 200MB and the migration stalled after the source files were fetched. Here’s a screenshot after almost 40 minutes

I think it’s an issue with the server. I’ll have our IT department take a look at it.

Screenshot of the Resource Monitor on the server:

Hey Tom,

These are tiny files they should take almost no time to do. People migrate files that are many GBS. These should be a breeze.

Let us know what you IT department says.

Todd

Todd, I uninstalled Otto 3 on the two servers, and the test migrations are working well so far. I did have one migration fail after the files were successfully fetched:

parsing options - Local Admin API error: Fetch failed: Unauthorized code: 956 - Maximum number of Admin API sessions exceeded; Path: /fmi/admin/api/v2/user/auth

I’m trying the same deployment again and the second time I didn’t get the error and the deployment is progressing. Do I need to increase the number of Admins API sessions that are allowed? If so, how is that done?

Tom

Hello Tom,

You shouldn’t need to increase the number of sessions. But that does suggest that something else is going on with your admin server. OttoFMS should only use one session. So something is using up the other sessions.

If you want you can change the number of sessions allowed by editing this file in your FileMaker server directory.

/Library/FileMaker Server/Admin/FAC/config/config.js

Restart the Admin server after saving that file.

Todd

Todd,

My OttoFMS migrations are still having issues not starting or completing. I need to go back to using Otto V3 until I can get our FMS servers rebuilt. From the last meeting we had I think that’s the best route for now to resolve the instability.
Where can I download the latest copy of Otto V3? I tried going to my proof-geist account purchase history but I can’t find the download link. I need to reinstall it on my main dev server.

Thanks

Todd,

Never mind, I finally found the right place in my proof-geist account.

Tom

Todd,

Sorry to keep bugging you guys. For the instabilities I’m seeing with OttoFMS/FM Admin tool, do you think it would be sufficient to do a clean install of FMS or is an entire server clean install?

Tom

You can also get the latest versions of Otto 3 here.

As for your current problem, it is hard to know what will fix it. But you could start with just the clean server install.

  • Remove FMS
  • Delete All folders
  • restart the server
  • Reinstall FMS

Also do not enable Persistent cache.

Todd

Hey Tom,

There were some fixes included in OttoFMS version 4.5.0 which should help with your issues with the strange stalling behavior. Let me know if things start getting any better or worse!!

-Kyle