Issue installing / upgrading v4.4 on macOS

I’m running into an issue upgrading to v4.4 on macOS. Server had 4.3.4 installed previously. I ran the uninstaller and then downloaded the 4.4 installer. I went this method because I’ve never been able to get the script upgrade method to work on macOS.

I ran the installer and it said it installed successfully. I checked Full Disk Access which had reverted to Off. I renabled full disk access for ottofms-macos-x64 and for OttoFMS-4.4. I then stopped and started OttoFMS via the command line.

When attempting to access the web console I get the error:
The requested URL was not found on this server. The link on the ">referring page seems to be wrong or outdated…

The only entry that gets added to the stderr.log files is:

(node:49286) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.
(Use ottofms-macos-x64 --trace-deprecation ... to show where the warning was created)

Hey Patrick,

Do you see anything in the otto-info.log file? The error about the Buffer is normal for OttoFMS installs.


Hi Patrick

Try restarting the HTTP Server.

fmsadmin restart httpserver


1 Like

Thanks Todd. Restarting the httpserver service resolved the issue.

1 Like