Migration crashing on Download from source to destination

I am getting regular crashes when attempting to deploy.

On Windows, source files are approx 260MB. Download gets to approx 75 - 80% before crashing.

I don’t have a .env file in OttoFMS/config, do I need to create one and set a custom timeout value?

For now I am using the ‘build’ method as a workaround but would like to get this sorted.

Hi Matt,

Can you give a little more information on the crash? What do the logs say? Is there an error message? How long does it take before it crashes?



Hi Todd

Thanks for the quick response.

The logs just show the file copying over then crashing at approx 14 mins in. I’ve tried it a few times and it crashes at around the same point each attempt.

I’ve attached screenshots if that helps, there doesn’t appear to be any more info in the otto logs.


Here is one from yesterday, as you can see I tried to resume deployment a couple of times, but no luck.

Hey Matt,

Can you send us the Ott-info.logs? The services is restarting, and I want to see what might be happening at that time.



I’ve sent them on a message.



It looks like there is a permissions issue on that backup folder and or drive.

error starting build EPERM: operation not permitted, lstat ‘D:\Backups\OttoFMS\outbox\jit_build_SfmTuK4yJhuc\jit_build_SfmTuK4yJhuc.build.zip’

Check that Backups folder. See if the permissions look off.

When you do the build work-a-round are you leaving the build on the server and just accessing it via build ID in OttoDeploy. Or are you using the Build URL method?



Thanks Todd

I think that may be a red herring. I had previous migrations crash with that error when I had a manual build in the folder. When I removed the manual build the migration then went ahead.
I’m using OttoDeploy with a Build URL.
I’ll check the permissions.