OttoFMS not Starting on Ubuntu 22 after update to 4.4.0

I have two servers that aren’t starting OttoFMS after updating to 4.4.0. I have uninstalled, removed the entire directory and reinstalled and still getting “not Found” on I’m also getting 501 Bad Gateway. This is after a reboot

Hi J

Check the logs to see if it actually booting up. There should be a otto-info.log file, and it should have some information about how far it it is is getting. If OttoFMS starting up looks like this in the logs:

time level message
2024-05-11T00:49:30.626Z info otto internal database up to date
2024-05-11T00:49:30.632Z info Listening on http://localhost:3061
2024-05-11T00:49:30.633Z info environment production
2024-05-11T00:49:30.633Z info version 4.3.4
2024-05-11T00:49:30.633Z info node version v20.11.1

If it gets to that point you know it is starting up. Are there any errors after that?

If the logs look fine but you can’t access the web page then the FileMaker web server may need to be restarted.

fmsadmin restart httpserver

Let us know what you find.



Have done the restart of the http server. The process is not starting, the Otto-info.log doesn’t have anything in it since 6/13/2024. More than a week ago, and the upgrade to 4.4.0 was done yesterday 6/21/2024. /var/log/syslog is showing

Jun 22 18:53:04 ip-172-31-41-160 systemd[1]: ottofms-proofgeist-com.service: Main process exited, code=exited, status=1/FAILURE
Jun 22 18:53:04 ip-172-31-41-160 systemd[1]: ottofms-proofgeist-com.service: Failed with result ‘exit-code’.

Hi J,

Have you been able to upgrade any other servers? Is it just these servers that you can’t upgrade?


Yes we have it running on 16 of the 20 servers. 3 of them are giving these errors the other one is giving the OttoDeploy error in the other thread

Hello J,

Could you run the following command and send me the output?

journalctl -u ottofms-proofgeist-com

This will get us the standard output logs for the underlying node process of OttoFMS, which should hopefully tell us more about why it is failing to start.


Here you go (6.8 KB)

ok, I found this one myself.

Turns out the fmserver didn’t have the right permissions to the backup directory. Updated that and it started right up.

Perfect!! I was just about to reply with almost that exact same thing. Was it the same issue on the other two servers?


Ok, I lied, that fixed one, but the other one, not so much give me a second and I’ll upload the logs for that one

1 Like

This one is giving a completely different error in the logs

log (3.5 KB)

Do the logs on that server have anything in the otto-info.log? That server looks like it is crashing on startup. its throwing an exit code 1, which means it may have an error logged in the OttoFMS logs.


no, they are also blank looks like it doesn’t like the Buffer() function? maybe that server get an update that the others didn’t maybe?

The Buffer function log is expected, that happens on every OttoFMS install. Are these all Linux machines?


Yes, Ubuntu 22.04 LTS on AWS

Could you run this and see if it gets us anything different?

sudo service ottofms-proofgeist-com status

Have you tried an OttoFMS reinstall on this server?


This is what that gave me. And this is after an uninstall and reinstall of OttoFMS on the server

ottofms-proofgeist-com.service - ottofms-service-proofgeist Loaded: loaded (/lib/systemd/system/ottofms-proofgeist-com.service; enabled; vendor preset: en>
Active: failed (Result: exit-code) since Wed 2024-06-26 20:57:25 UTC; 17s ago
Process: 301031 ExecStart=/opt/OttoFMS/bin/ottofms-linux-x64 (code=exited, status=1/FAILURE)
Main PID: 301031 (code=exited, status=1/FAILURE)
CPU: 861ms

hmm well that doesn’t give us any great information either. This one is a conundrum. I’ll double check with our hosting team and see what other options we have for troubleshooting. If you want to look at it together please sign up for Office Hours!!


ok, I will do. I have tried resetting permissions, uninstalling, reinstalling, uninstalling and reinstalling an older version, and then upgrading. Nothing seems to be working. I even rm -rf the /opt/OttoFMS directory and this thing just doesn’t want to cooperate on this one server.