Add Functionality to Filter Deployments List

It would be helpful to have a way to quickly filter the list of deployments from the Deployments view. With a large number of clients and a number of different types of deployments for each one it can be difficult to find the one you are looking for.

The global search is handy, but it would be useful to be able to find particular deployments without having to free type.

Otto v3 had the ability to set a client for each deployment. It would be nice to have the functionality to filter by client.

Something like the below where you could tag deployments, then quickly filter by the tags. For example “Client A Name”, “Client B Name” etc as well as “Type A”, “Type B”. Being able to add client logos would also be very useful as well.

Hey Gabe,

Thanks for the feedback! I agree we need some ability to search and filter the deployments in the list. tags is a good idea, could let you organize your deployments more distinctly. We’ll be looking into ways to make this easier to work with when you have lots of deployments!


I second this request!

My Otto Migrator file was configured with 34 migrations. OttoDeploy would be better with a way t filter the list.


Hey y’all,

OttoDeploy version 1.1.0 has much more granular filtering and sorting for the deployments table. It should help with finding your deployments. We’re still looking into adding tags or clients that you can add to a deployment so you can search more granularly by them.

Thanks for the suggestions!


1 Like

LOVE IT! But I found a bug and can’t get around it.

I filtered my list for “UIs”. I checked all of the files I wanted to mark. Then selected the option to “Hide Unchecked” Great! Until you deselect all…

The list is empty now and the “Hide Unchecked” option is gone.

There are 30 deployments in the table. I can’t get the list to view. I have also closed/reopened the file.


Oh gosh that is an unfortunate bug. I’ll get on this, likely going to release a small version of OttoDeploy to fix this soon. If I find a workaround for the issue I’ll let you know!


OttoDeploy version 1.1.1 was just pushed up, it fixes this issue! You should now be able to turn off the hide unchecked flag even when there are no deployments selected. Thanks for the report Jeff!


Got it back! Thanks!