Adding server states I do not have OttoFMS installed

Apologies in advance if I am missing something in plain sight. I am trying to add a server to OttoDeploy, however, when trying to test the server before adding, it will tell me that I don’t have OttoFMS installed on the server. It does recognize my FMS version though.

Below is a screenshot of the error and also a screenshot of the OttoFMS login in page showing my FMS version along with the OttoFMS version. Any ideas on what I am potentially missing?

Screenshot of error: ( I masked the URL but it is in there)

Screenshot of OttoFMS login page:

Hi Alex,

Welcome to the community. :slight_smile:

Are you by any chance White Listing IP addresses through the Admin Console? Because if you are, you will need to add your computer’s IP address to that for OttoDeploy to connect to the server fully.

Let us know if that is it.



Hi Todd,

Thank you for getting back to me, I appreciate it!

I just went in and checked and have no white listed IP addresses through the admin console. I even went ahead and added both IP addresses, whitelisting both our Production server IP address and our Development server IP address and tested at that point and I still get an error that OttoFMS is not installed on either server.

I can try uninstalling OttoFMS potentially and re-installing, but I’m not sure if that would be even remotely helpful.

Thank you,


Hi Alex,

Remove all the white listed stuff since you weren’t using it.

So with that out of the way, lets return to the URL.

Are you using http or https?
Are you using Claris’s self signed cert? Or do you have a proper ssl cert in place?


Hi Todd,

I have removed the white listed IPs.

I am using https and I am currently using the Claris self-signed cert. I am not entirely sure how to go about getting a proper ssl cert, although I would prefer to, especially if it will resolve this issue.


Hello, to all.

I have a similar problem. I use self-signed certificates on two test servers in my local network. If I try to add these machines I get this error. When I try to add a server located in AWS with a proper SSL certificate - all work well.

Hello :slight_smile:

Welcome to the community.

Sorry but we do not support self signed certs at this time. We are working towards some options for handling this in the future, but we don’t have any time line for this yet.

Right now, the easiest thing to do here is to just get a valid cert or use something like ngrok.

Hope that helps



Hello, Todd!

Thank you for the clarification.


Question, should this work via just IP address without SSL at all, or is SSL required? When we try to add a FM server were seeing the FM version, but its claiming that OttoFMS is not installed when adding a server using for example.

Hello CarlB

Welcome to the community :slight_smile:

Sorry no. It won’t work. OttoFMS requires a fully qualified domain and a valid SSL certificate.



Thanks for the reply, Todd, if I may suggest a few things; your previous comment asking if http or https was in use sort of lead me to believe that http would be supported, which is also suggested by this document Coming from Otto v3? | OttoFMS where its mentioned that V3, and presumably newer, work on the same port as file maker, 80/443, which also seems inaccurate since 80 is plain text no SSL. I also did not see anything in the setup documentation that mentioned this requires a FQDN and proper, not self signed, SSL.

Hi Carl

You are right we could do a better job of calling that out in the docs. I have made some changes to the docs to make that clearer.



1 Like