Advanced Options Preference Not Working

I am working through rebuilding my migrations scripts from the old version of Otto to OttoDeploy and ran into another bug.

I enabled the preference “Use advanced deployment settings by default”.

However, with each new deployment it is defaulting to the Simply Options:

Let me know if you have any questions.

Thanks,
Jeff

Thanks for the report Jeff! I have a fix put together for this issue, we’ll be publishing a new version to fix it later this week. Thank you!

Hey Jeff,

We’ve fixed this issue as part of OttoDeploy version 1.1.0! Thanks for the report.

-Kyle

It wasn’t clear to me that I had to both enable Advanced Options, and then select use advanced options from the deployment’s ellipsis menu.

Thank you.

The setting is where you set the default for new deployments. Any new deployments will have they options enabled. Old ones will still need to be manually switched
Here is what the ui looks like

TG2024-04-22 at 07.00.50

What do you think we could change here?

Todd

Wording? “Default all new deployments to advanced settings?” Then, if possible, in smaller text, “Existing deployments can be switched to advanced using this menu.”