Blank screen when opening Deploy

I used Deploy to configure a migration and successfully ran that migration.
I open deploy to run that migration again and get a blank web viewer instead of the screen to actually run the deployment. Any assistance to get over this hurdle?

Hey Mike,

If you press CMD+R while in OttoDeploy does it refresh the web viewer for you?


Hi Mike,

Can you send us a screen shot of what you see?



Hi Mike

I suspect that a record was deleted or that there are no found records in your found set. Check to see if you have no found records. You may need to choose Full FileMaker Menus

If you have no records in your found then closing the file and reopening the file should fix it.

I am not sure how that happened. And I’d like to figure what caused it so please let me know what you find out.



(I am getting mike’s messages, but they aren’t appearing here) :person_shrugging:

Hi Mike,

I think somehow all your data got deleted. I sure would like to know how that happened. Any chance you cloned the file? I suspect all your server records are gone now too.

I would like to figure out what happened but first I would like your file not to be broken. If you haven’t set up too many deployments, I would just throw that file out, and start over.

This isn’t something we have seen before, despite many many deployments getting run from OttoDeploy over the last few weeks. So whatever happened I don’t think it is common.



We are running into blank screens in OttoDeploy regularly. Sometimes on open, sometimes after trying to add/select a slack channel url to send notifications.

Pretty consistently, when clicking “Add New” in the the one screenshot, we get a completely blank window ( the other screenshot ).

Hi Josh,

Thanks for reporting this. Sadly I still can’t replicate it. I just tried again, by adding a new Slack notification.

We have about 3 people who have reported this, so I know it is real thing. but we haven’t been able to figure out what is different.

Can you share more about your environment?

Mac or windows?
version of FMS?

Also what do you do to get the screen back?



Client: Mac FileMaker Pro 19-20.3.2 ( all exhibit the same behavior )
Server: Ubuntu 22.04.3 LTS ; FileMaker Server 20.3.2
OttoDeploy: 1.2.4
OttoFMS: 4.3.5

Note, this is happening from different mac machines from every person we have that accesses this file. So it feels like it’s something related to the server.

We have the webhook urls setup already.
In the deployment options, the only way to add one of the urls is to click “add new”
Then… blank screen. We have had this happen several times in the past, but it’s pretty consistent now, we never get past the blank screen, unless there are already no urls already setup.

I’m double checking that Otto has permissions to post to the channels… but one of the is working. That second one from the bottom of the Notification settings panel.

Hi Josh,

How do you get the screen back?


If I reload the webviewer ( cmd+r ), it takes me back to the deployment list screen, where it lists all the deployments. I’ve also quit FMP completely, and restarted.

This same behavior happens if I create a new deployment.

Wow that is pretty strange.

Maybe if you come by Office Hours we could take a look under the hood a little bit.


Ok. Made progress. I did 2 things:

  • I manually filled in the json data for notifications for the deployment records in OttoDeploy, that I couldn’t set before.
  • I manually removed 1 of the array rows from the API_SETTINGS json data. ( there were 2 entries with the same label/name, but different URLs )

Now the window is showing as expected. I’m not sure which of the 2 things fixed it ( missing data in the json or multiple “Notification Settings” with the same label in the settings )

Thanks Josh

That is helpful information.


1 Like