Build server is unreachable: fetch failed: Error: unable to verify the first certificate

Dear Team,

I have been successfully using the OttoFMS and OttoDeploy tools.

Currently, on one server, I keep getting the following error:

Build server is unreachable: fetch failed: Error: unable to verify the first certificate

Can I get some indication as to why this keeps happening?

I am trying to move a copy of my Databases from my Production Server to the Development Server so that it moves with the Data. I am doing a Replace/Install Operation.

Hello Aly,

Welcome to the community, its good to have you!

That error indicates that there is an issue with the certificates on your web server. In this case it means that somewhere in the certificate chain, presumably somewhere on your source server, there is a missing or invalid SSL certificate. I would try verifying your certificate setup on your servers to make sure everything is working as intended.

Is this the first time you’ve used this server as a source? If this suddenly started happening on a server that was working perhaps one of your certificates expired, otherwise I suspect the error is due to a missing or misconfigured cert.

-Kyle

Hi Kyle,

The SSL is perfectly valid till 2024-06-08 23:59:59 UTC

I do not know what the problem could possibly be wrong.

If I run a deployment from the Dev to the Production server, it seems to be working just fine.

Aly

Hello Aly

You may want to try reinstalling the certificate on that machine. Make sure you install the intermediates when you do that.

You could also try an SSL Checking tool.

https://www.digicert.com/help/

They will warn you if you aren’t using there service, but the rest of the validations are pretty good.

Todd

1 Like

Hello, i have the same problem like this man.
I check my ssl cert from digicert and everything is ok. all green.
in the prod and the dev server.
Maybe something like firewall or something ?
Please help me.

Hi.

We resolved the problem as one of the SSL was broken in its chain. Something it happens that you need to re-install the SSL.

Use the following tool and scope all your servers:

This is what solved our issue where we noticed one of them was broken.

Goodluck and let me know if it works.

1 Like

Yes. That is what we see as well.

Reinstalling the certs and making sure to include the intermediate bundle solves this problem most of the time.

Thanks

Todd