Deployment Error Msg in manifest.json file in the OttoFMS Outbox


Just installed OTTOFMS and tried my 1st migration but it failed. I went into the “Ottofms Outbox” folder using the File Manager and found under my build this error msg below in the manifest.json file. . .

message": “backup or copy failed: TEST4OTTO.fmp12. Error: ENOENT: no such file or directory, scandir ‘C:\Program Files\FileMaker\FileMaker Server\Data\ClonesOnly\OTTO_TEST4OTTO.fmp12_EXTGA\’”

Any ideas on how I may be able to fix this.


Hello Dominick,

Which version are you running? there was an error in version 4.0.8 which would cause that message. Upgrading to 4.0.9 will fix the issue.


Hello Kyle:

I was running 4.0.6. I just tried to install 4.0.9 and I got this error message. . .

"Problem running post-install step. Installation may not complete correctly
Error running C:\Program Files\OttoFMS/bin/nssm/nssm.exe start com.proofgeist.ottofms: c


Hello Dom,

Which OS are you running OttoFMS on? Are you running FileMaker server with the default fmserver user? Which FileMaker Server version are you running?


Hi Kyle:

I’m running Windows. Filemaker Server

After the upgrade to 4.0.9. . . This message was in the manifest.json file in the outbox. Regarding the default fmserver user - can I find that in the admin console??? It is possible we may not be running with the default. We do have a valid SSL Cert.

“message”: “backup or copy failed: TEST4OTTO.fmp12. Error: ENOENT: no such file or directory, scandir ‘C:\Program Files\FileMaker\FileMaker Server\Data\ClonesOnly\OTTO_TEST4OTTO.fmp12_AHFYy\’”,
“lastUpdated”: “2024-02-05T21:21:16.526Z”

Hi Dom,

If you have successfully run OttoFMS the fmserver user shouldn’t be a problem, I was mostly wondering since you had the install problem. If you’ve got OttoFMS up and running again you should be fine.

Do you mind DMing me your otto-info.log and your otto-error.log contents for the time of the error? You can find these in the logs page of the OttoFMS console:
CleanShot 2024-02-05 at 14.41.01

I want to make sure I know at which part of the process your build is failing. Thank you!



Do you want me to use the upload link to send the files?


Hello Dom,

You can direct message @kduval with anything you might feel is sensative.


No problem Todd. Kyle’s been fabulous with his help.


For anyone who comes along with this same error, the error is a result of attempting to migrate a file into itself (same file on the same server). We are working on a safeguard for this in OttoDeploy coming in a future version, since the error you get after the migration has started is not very helpful. Essentially what happens is we close the file to start the deployment, then we attempt to create a clone of the file with FileMaker. The clone fails since FileMaker cannot make clones without the file being open (at the moment).