Error accessing

Installed on Mac FMS host with, when I use /otto/ with a FQDN I get back an error. FWIW, any directory other than the FMS defaults like /admin-console/ or /fmi/webd/ gives that.

Also tried to start from command line. OS is ventura 13.6.1

xxx@FMS ~ % sudo launchctl bootstrap system /Library/LaunchDaemons/com.proofgeist.ottofms.plist
Bootstrap failed: 5: Input/output error
xxx@FMS ~ %

Uninstalled threw an error about removing the reverse proxy.

Hey Andy

That doesn’t look like Otto is installed or if it is it isn’t running
Can you check the Activity Monitor for β€˜ottofms’

Is it it running?



Also if OttoFMS is installed and running it should be generating logs in the Logs folder. See image.

Whats in those logs?

Send them to me via Direct Message here and I can take a look.



No process running, logs is empty. I just did a reinstall too.

Are you getting an error when you run the installer?

Because it clearly isn’t completing the install. You should at the very least get stdout and stderr logs.

Can you send a screen shot of the final installer window?

You might be able to find something in the system logs. Look for β€œotto”

And finally if something did get jammed up, deleting the entire OttoFMS folder after you uninstall and before you re-install might help.



Also we did just release a new version of OttoFMS.


Hi Todd, great product!

I have an installation issue, too:
2024-01-17T17:04:35.783Z error Error installing reverse proxy

(node:1175) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.
(Use ottofms-macos-x64 --trace-deprecation ... to show where the warning was created)

e[32minfoe[39m: otto internal database up to date
e[32minfoe[39m: Listening on http://localhost:3061
e[32minfoe[39m: environment β€œproduction”
e[32minfoe[39m: version β€œ4.0.1-beta.21”
e[32minfoe[39m: This beta version will expire in 13 days
e[32minfoe[39m: started watching offsite backup
e[32minfoe[39m: started watching for hostname changes
e[31merrore[39m: Error installing reverse proxy {β€œ0”:β€œE”,β€œ1”:β€œr”,β€œ10”:β€œC”,β€œ100”:β€œn”,β€œ101”:β€œf”,β€œ102”:β€œ/”,β€œ103”:β€œh”,β€œ104”:β€œt”,β€œ105”:β€œt”,β€œ106”:β€œp”,β€œ107”:β€œd”,β€œ108”:β€œ.”,β€œ109”:β€œc”,β€œ11”:β€œE”,β€œ110”:β€œo”,β€œ111”:β€œn”,β€œ112”:β€œf”,β€œ113”:β€œ'”,β€œ12”:β€œS”,β€œ13”:β€œ:”,β€œ14”:" β€œ,β€œ15”:β€œp”,β€œ16”:β€œe”,β€œ17”:β€œr”,β€œ18”:β€œm”,β€œ19”:β€œi”,β€œ2”:β€œr”,β€œ20”:β€œs”,β€œ21”:β€œs”,β€œ22”:β€œi”,β€œ23”:β€œo”,β€œ24”:β€œn”,β€œ25”:” β€œ,β€œ26”:β€œd”,β€œ27”:β€œe”,β€œ28”:β€œn”,β€œ29”:β€œi”,β€œ3”:β€œo”,β€œ30”:β€œe”,β€œ31”:β€œd”,β€œ32”:”,β€œ,β€œ33”:” β€œ,β€œ34”:β€œo”,β€œ35”:β€œp”,β€œ36”:β€œe”,β€œ37”:β€œn”,β€œ38”:” β€œ,β€œ39”:”'β€œ,β€œ4”:β€œr”,β€œ40”:”/β€œ,β€œ41”:β€œV”,β€œ42”:β€œo”,β€œ43”:β€œl”,β€œ44”:β€œu”,β€œ45”:β€œm”,β€œ46”:β€œe”,β€œ47”:β€œs”,β€œ48”:”/β€œ,β€œ49”:β€œM”,β€œ5”:”:β€œ,β€œ50”:β€œa”,β€œ51”:β€œc”,β€œ52”:β€œi”,β€œ53”:β€œn”,β€œ54”:β€œt”,β€œ55”:β€œo”,β€œ56”:β€œs”,β€œ57”:β€œh”,β€œ58”:” β€œ,β€œ59”:β€œH”,β€œ6”:” β€œ,β€œ60”:β€œD”,β€œ61”:”/β€œ,β€œ62”:β€œL”,β€œ63”:β€œi”,β€œ64”:β€œb”,β€œ65”:β€œr”,β€œ66”:β€œa”,β€œ67”:β€œr”,β€œ68”:β€œy”,β€œ69”:”/β€œ,β€œ7”:β€œE”,β€œ70”:β€œF”,β€œ71”:β€œi”,β€œ72”:β€œl”,β€œ73”:β€œe”,β€œ74”:β€œM”,β€œ75”:β€œa”,β€œ76”:β€œk”,β€œ77”:β€œe”,β€œ78”:β€œr”,β€œ79”:” β€œ,β€œ8”:β€œA”,β€œ80”:β€œS”,β€œ81”:β€œe”,β€œ82”:β€œr”,β€œ83”:β€œv”,β€œ84”:β€œe”,β€œ85”:β€œr”,β€œ86”:”/β€œ,β€œ87”:β€œH”,β€œ88”:β€œT”,β€œ89”:β€œT”,β€œ9”:β€œC”,β€œ90”:β€œP”,β€œ91”:β€œS”,β€œ92”:β€œe”,β€œ93”:β€œr”,β€œ94”:β€œv”,β€œ95”:β€œe”,β€œ96”:β€œr”,β€œ97”:”/",β€œ98”:β€œc”,β€œ99”:β€œo”}
e[32minfoe[39m: License status: undefined

Any ideas? Can I send you the log files?

Best, Mario

Hi Mario :slight_smile:

The error that is hidden in there is

Error: EACCES: permission denied, open β€˜/Volumes/Macintosh HD/Library/FileMaker Server/HTTPServer/conf/httpd.conf’

OttoFMS runs as fmsadmin:fmserver. Your httpd.conf file should be owned by the same user. If it isn’t then that would explain this error.

  1. Did you install FileMaker Server with a customer account and group? Or did you just accept the default user? OttoFMS requires the default setup. It will not work with a custom account name and group.

  2. Check to see what the privileges are on that file and everything in it’s path. It should look like this.

If any of those folders or files doo not have the proper permissions that would cause this error.

In order to run OttoFMS you will need to fix those permission. One way to do that would be to uninstall FileMaker Server, delete all the folders, and re-install. You could also fix them manually. .

Once that is done, try starting OttoFMS again. Let us know what you see, or if you have other questions

Thanks for trying OttoFMS


Hi Todd,

thank you very much for the quick and helpful response. You were right, however, it was the other way round in this case: FMS was installed with standard credentials, but for some reason, the privileges of the HTTPServer folder were wrong. Anyway, you solved it. Can’t wait to setting up OttoFMS on all our customers’ servers and EVENTUALLY deploy and update the way it’s supposed to be. Cheers, Mario!

1 Like

I had to go to Mac security and set Otto to have full disk access. Then it started writing to logs. Install itself was fine - got the dialog at the end to open readme.

Ah yes - Thanks for letting us know. At least some of the time the OS will trigger a dialog asking if that is ok. But I am not clear why it doesn’t always do that. We need to add a note to the docs about it.



Uninstalled an older version and installed 4.1 today. Logs look OK (shown below) but we get requested url was not found on the server. I went to mac security and removed/re-added Otto and did the stop/start on the process a few times. No go.

[32minfoe[39m: otto internal database up to date
e[32minfoe[39m: Listening on http://localhost:3061
e[32minfoe[39m: environment β€œproduction”
e[32minfoe[39m: version β€œ4.1.0”
e[32minfoe[39m: started watching offsite backup
e[32minfoe[39m: started watching for hostname changes
e[32minfoe[39m: Reverse Proxy already installed
e[32minfoe[39m: License status: valid

Hi Andy

If it is making logs it isn’t the Disk permission issue. This sound more like the reverse proxy isn’t getting configured correctly. Could you try uninstalling and reinstalling OttoFMS?

Let us know



One other thing . On Mac the url to /otto/ REQUIRES the trailing slash.

Could that be it?

If not can you send us a screen shot of the error you see?



I did uninstall/reinstall 2x.

Ok possibly your Webserver needs to be restarted.

You can do this with `fmsadmin restart httpserver" on the command line.

Also can you confirm that OttoFMS is indeed running. Using the activity monitor you should see a process called ottofms-macos-x64

Make sure you are viewing all processes.

Let us know