Offsite Backups to AWS S3

I’m using OttoFMS 4.2.2 and have Offsite Backups enabled. I can see that the backups are being created, but nothing is ending up in S3 and I think the reason is that the region isn’t being saved (correctly).

In the config UI when I complete all details and hit Test, it works as expected. When I go back in to edit those credentials the Region field is now empty and a test fails. Putting the region back in and it works for the test.

However, as I said above nothing is being uploaded and when I review /opt/OttoFMS/logs/otto-error.log I find:

ERROR : Attempt 1/3 failed with 1 errors and: AuthorizationHeaderMalformed: The authorization header is malformed; the region 'us-east-1' is wrong; expecting 'eu-west-2'
	status code: 400, request id: 8PY3MJ4W0165NTS0, host id: JFienHHdWD/z4FtepGSnz1+38efkerG6z3D/FlPonMtiQsm7/cPmc8LdICUWL0KwqX/Yi8/JXio=

Which is consistent with the behaviour in the UI - that the Region field isn’t being saved / used by default for connections to S3.

While we could create a bucket in eu-east-1, which is what it seems to want, we’d prefer to keep everything in the same DC if at all possible.

Thanks for any feedback.

Hey Steve,

This issue was fixed in OttoFMS version 4.2.3. There is also an important security fix in 4.3.4 which you should install, I would recommend upgrading to the most recent version of OttoFMS by following the upgrade docs and re-entering your S3 credentials into the settings. Thank you!


Thanks Kyle - updated, region saved - I’ll know in about 14 hours if it worked :slight_smile: