"Override FileMaker Server Name" Won't Turn Off

We had accidentally turned on the “Override FileMaker Server Name” option in Settings > Appearance, which successfully updated the name in FMS to be “[PROD] ServerName”. Since this was a mistake, we turned this setting off so that we could remove the “[PROD]” prefix and keep the names independent, but attempts to change the name via FMS Admin Console or the Admin API are not sticking. ‘ServerName’ is just a stand-in for the actual server name, here.

Example log entries from Event.log:

2024-06-10 16:29:18.415 +0000	Information	116	Temp Name	Server host name type: Custom
2024-06-10 16:29:18.415 +0000	Information	1045	Temp Name	Web Publishing Engine (Temp Name) is configured.
2024-06-10 16:29:18.416 +0000	Information	120	Temp Name	Server host name: Temp Name
2024-06-10 16:29:18.438 +0000	Information	116	[PROD] ServerName	Server host name type: Custom
2024-06-10 16:29:18.438 +0000	Information	1045	[PROD] ServerName	Web Publishing Engine ([PROD] ServerName) is configured.
2024-06-10 16:29:18.438 +0000	Information	120	[PROD] ServerName	Server host name: [PROD] ServerName

So it seems that some OttoFMS listener is immediately picking up on a name change and reverting it back to the OttoFMS style name, even though the “Override FileMaker Server Name” setting is off.

I’ve tried restarting OttoFMS and rebooting the entire machine, but it seems firmly stuck ON.

FileMaker Server v20.3.2.205
Ubuntu Linux 22.04 LTS on x86
OttoFMS v4.3.5

Hey Matt,

Thanks for the report, I’ve isolated the source of this and I’m putting a fix together to be included in the next version of OttoFMS. Unfortunately there is not a simple workaround for this issue, I expect to have a new version released in the next couple of weeks with this fix included. Thank you!


1 Like

This was fixed with OttoFMS version 4.4.0!

1 Like