Post deployment script didn't call "done", reverting

OttoFMS reports the following when trying to run a post-deployment script:

Post deployment script didn’t call “done”, reverting

I’m not seeing anything in the docs about how to call “done” from the post-deployment script: Post Deployment Scripts | OttoFMS.

Originally my post-deployment script didn’t exit with any specific result. I tried exiting with 0, but I still get the same error.

How should the post-deployment script be set up to resolve this error?

You are right, Sorry about that. We used to have an example file with a script in it that showed how to do it

Let me dig it up.



Ok I am going to add this to the docs but here is an example file. It has some scripts that You can use as a model for how to tell OttoFMS that your script is done.

PostDeploymentScriptEx.fmp12 (272 KB)

BUT… if you don’t want the Deployment To Revert you can just leave the toggle off for “revert the deployment …” Like this.

Did you have that turned off? If you did then we may have a bug. Let us know.



I rearranged the docs a bit and added the file there as well


1 Like

Thanks for the quick response. I added the script from your example file, and it’s working as expected now.

Thank you also for the great tool and for making it available to the community for free.

In case anyone else is reading this and is wondering what happens to the “otto-pms-result.txt” file that the post deployment script creates in the Documents folder, OttoFMS seems to remove it automatically.

Glad that worked for you.

Yup OttoFMS is watching for that file. When it finds it, it reads it and then deletes it.



1 Like