Remote Storage Settings for Offsite Backup Does Not Save Region Value

Our nightly backups are not successfully being uploaded to S3 and it appears to be related to a malformed header listing the incorrect region. This is what I’m seeing in the logs:

2024/03/07 21:05:53 Failed to copy: AuthorizationHeaderMalformed: The authorization header is malformed; the region ‘us-east-1’ is wrong; expecting ‘us-west-1’

When setting up the connection I’m using the following values:
Region: us-west-1

I’m able to successfully test the connection before saving my settings, however when I go back in to edit them I’m noticing the region settings aren’t saved and are instead showing the default value of “us-east-1”. Leaving the region value blank results in an unsuccessful connection test.

Hi Mike,

Thanks fore reporting this. We will check it out ASAP.


I can confirm the issue, and a fix will be included in the next release.

Thanks for reporting


The thanks go to you and your team – such a great product!

Thank you!

1 Like

Hello Mike,

The fix for this issue was shipped as part of version 4.2.3 which was just released. Let us know if you have any other issues!


Thanks, Kyle! I upgraded last night and can confirm everything is working now as expected.