Setting Up Remote Storage

Hi im having an issue setting up remote storage, we know the keys are correct as we can add attachment via another route using the keys, the Bucket name is correct, is the issue with the end point or the Region?

Hello :slight_smile:

Welcome !

I think you have it setup correctly. We may have an issue where a connection errors isn’t cleared properly if you tried once with the wrong credentials and then tried again correctly.

Try this.

Do a full page refresh on the Settings page. That should clear any form state that might be stuck.

Then try again. Enter everything as you did before, like what you showed in the picture.

If that doesn’t work we’ll have to set up some credentials in that region, and try it here.

Let us know what happens.



Thanks Todd, tried to refresh still no joy i also tried from another server we have OTTO on no joy on that

Hey Malcolm,

Do you see any errors in your otto-info.log? If so could you send them along to me via DM? I’ll be the one working on this issue.

Alternatively, if you have a way to get the full error message from that modal you sent us a screenshot of that would be great. The error should appear in the browser console. If you right click and click “Inspect Element” the error should appear on the HTML element and in the console. Thank you!


Sorry i replied via emails not the ticket sent this on the 25th

Hi Kyle

Many thanks for responding to this thread

I believe this is the error you are after

{“error”:{“message”:“"input" needs to be an object when doing a batch call”,“code”:-32600,“data”:{“code”:“BAD_REQUEST”,“httpStatus”:400,“stack”:“TRPCError: "input" needs to be an object when doing a batch call\n at Object.TWe [as getInputs] (/snapshot/ottofms-server/index.js)\n at uqr (/snapshot/ottofms-server/index.js)\n at process.processTicksAndRejections (node:internal/process/task_queues:95:5)\n at async /snapshot/ottofms-server/index.js\n at async /snapshot/ottofms-server/index.js”}}}


Hey Malcolm,

I don’t think that is our error here. Could you try to connect and look at your browsers console? You can get there by right clicking and selecting “Inspect Element” then going to the console tab. There should be an error logged there if it is not in the otto-info.log. I’m looking for the full error that you see in the error message on your screenshot you sent. That error is the one coming back from the attempt to connect to your bucket.


Will this help

1 Like

Yes! I’ll take a look