UI won't load after Script Update to 4.2.4 - Monterey 12.7.2

Oddly, the update script worked just fine on our Dev server, but completely borked the web UI on Production. It had all permissions prior to the upgrade, but I noticed that Full Disc Access was reset afterwards.

Despite this entry in stderr.log, I watched it create the needed folders. Activity Monitor showed ottofms-macos-x64 was actually running, but the web UI wasn’t being served.

Node.js v18.5.0
    throw err;

Error: EACCES: permission denied, mkdir '/Volumes/BACKUPS/Backups/OttoFMS'
    at Object.mkdirSync (node:fs:1394:3)
    at Object.mkdirSync (pkg/prelude/bootstrap.js:1639:33)
    at /snapshot/ottofms-server/index.js
    at lZt (/snapshot/ottofms-server/index.js)
    at Object.<anonymous> (/snapshot/ottofms-server/index.js)
    at Module._compile (pkg/prelude/bootstrap.js:1926:22)
    at Module._extensions..js (node:internal/modules/cjs/loader:1166:10)
    at Module.load (node:internal/modules/cjs/loader:988:32)
    at Module._load (node:internal/modules/cjs/loader:834:12)
    at Function.runMain (pkg/prelude/bootstrap.js:1979:12) {
  errno: -13,
  syscall: 'mkdir',
  code: 'EACCES',
  path: '/Volumes/BACKUPS/Backups/OttoFMS'

Running the uninstaller, then the macOS installer worked.

Hi Jason

I don’t think the update had anything to do with it. I think your Full Disk access permissions getting reset was the cause. Updating it with the script, just stopped and started the service, and it was that stopping and starting that caused the permissions issue to show up.



Hey Todd,

It had permission before the update. However, even enabling the Full Disk Access after the update did not allow it to fully run. I could watch it modify the external drive folders, but the UI would never load, even with Full Disk Access enabled.

Re-enable permission, stop, start, then still no UI when it was literally creating folders on the external drive.

That’s the really odd bit. I’ve been down that path a lot. :slight_smile: